Commit 48dc825c authored by Ismail Faizi's avatar Ismail Faizi

use latest SDK and update accordingly

parent 645632ae
......@@ -8,23 +8,15 @@
# - coverage
# - webtest
FROM google/cloud-sdk
FROM google/cloud-sdk:latest
MAINTAINER Ismail Faizi <ismail@softence.com>
LABEL maintainer="Ismail Faizi <ismail@softence.com>"
# Install Google App Engine SDK for Python
RUN wget --no-check-certificate -O /tmp/gae.zip https://storage.googleapis.com/appengine-sdks/featured/google_appengine_1.9.40.zip
RUN unzip /tmp/gae.zip -d /gae-python
ENV PATH /usr/lib/google-cloud-sdk/platform/google_appengine:$PATH
ENV PYTHONPATH /usr/lib/google-cloud-sdk/platform/google_appengine:$PYTHONPATH
ENV PATH /gae-python/:$PATH
ENV PYTHONPATH /gae-python/google_appengine:$PYTHONPATH
# Install pip
RUN apt-get install -y python-pip
# Install pil
RUN apt-get install -y python-pil
# Install nose and Google App Engine plugin
RUN pip install nose
RUN pip install nosegae
RUN pip install coverage
RUN pip install webtest
RUN pip install nose nosegae coverage webtest
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment